Solucionar el conflicto de versiones - servicios de google

Solucionar el conflicto de versiones - servicios de google

Soy un novato en la plataforma Android y estoy tratando de hacer un sistema de inicio de sesión con base de fuego en él. He visto y seguido algunos tutoriales y el código está bien. Mi problema está en "Module:app", donde tengo un conflicto con las versiones:

Solucione el conflicto de versiones actualizando la versión del complemento de servicios de Google (la información sobre la última versión está disponible en https://bintray.com/android/android-tools/com.google.gms.google-services/) o actualizar el versión de com.google.android.gms a 11.2.2.

Aquí está mi código Gradle: Módulo:aplicación

apply plugin: 'com.android.application'


android {
compileSdkVersion 26
defaultConfig {
    applicationId "com.example.diogo.VicenteAPP"
    minSdkVersion 15
    targetSdkVersion 26
    versionCode 1
    versionName "1.0"
    testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
}
buildTypes {
    release {
        minifyEnabled false
        proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
    }
}

}

dependencies {
implementation fileTree(include: ['*.jar'], dir: 'libs')
//noinspection GradleCompatible
implementation 'com.android.support:appcompat-v7:26.1.0'
implementation 'com.android.support:design:26.1.0'
implementation 'com.android.support.constraint:constraint-layout:1.0.2'
implementation 'com.google.android.gms:play-services:11.2.2'
implementation 'com.google.android.gms:play-services-location:9.2.0'
implementation 'com.google.firebase:firebase-auth:11.2.2'
implementation 'com.google.android.gms:play-services-auth:11.2.2'
android {
    defaultConfig {
        multiDexEnabled true
    }
}
testImplementation 'junit:junit:4.12'
androidTestImplementation 'com.android.support.test:runner:1.0.1'
androidTestImplementation 'com.android.support.test.espresso:espresso- 
core:3.0.1'
}

apply plugin: 'com.google.gms.google-services'

Si borro esta línea: apply plugin: 'com.google.gms.google-services', no aparecerá ningún error pero la aplicación explotará

¿Qué debo hacer para solucionar este dolor de cabeza?

Mostrar la mejor respuesta

Ponlos todos (gms-services-version) en la misma versión :-

Usar

implementation 'com.google.android.gms:play-services-location:11.2.2'

en lugar de

implementation 'com.google.android.gms:play-services-location:9.2.0'