No se pudo completar la compilación

No se pudo completar la compilación

https://github.com/Xares01/TimeZoneWorld

Dice en la compilación:

Android issues: Program type already 
present: com.google.android.gms.auth.api.signin.internal.zzo    

Antes de experimentar con el archivo de la aplicación build.gradle porque se quejaba de las diferentes versiones, lo que no debería haber hecho.

Este es mi archivo build.gradle actual:

android {
    compileSdkVersion 27
    defaultConfig {
        applicationId "com.example.jimjohansson.timezoneworld"
        minSdkVersion 16
        targetSdkVersion 27
        versionCode 1
        versionName "1.0"
        testInstrumentationRunner     
        "android.support.test.runner.AndroidJUnitRunner"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'),    'proguard-rules.pro'
            }
        }
    }

    dependencies {
      implementation fileTree(dir: 'libs', include: ['*.jar'])
      implementation 'com.android.support:appcompat-v7:27.0.2'
      implementation "com.android.support:cardview-v7:27.0.2"
      implementation ('com.github.bumptech.glide:glide:4.5.0',{
          exclude group: 'com.android.support'
      })
      implementation 'com.android.support.constraint:constraint-layout:1.0.2'
      testImplementation 'junit:junit:4.12'
      androidTestImplementation 'com.android.support.test:runner:1.0.1'
      androidTestImplementation 'com.android.support.test.espresso:espresso-   core:3.0.1'
      implementation 'com.firebaseui:firebase-ui-auth:3.2.2'
      implementation 'com.google.firebase:firebase-auth:12.0.1'
      implementation 'com.google.android.gms:play-services-drive:12.0.1'
      implementation 'com.android.support:support-v4:27.0.0'
    }

    apply plugin: 'com.google.gms.google-services'
Mostrar la mejor respuesta

agregue su registro de errores

@NikunjParadva Veo muchos errores en el registro. ¿Cómo puedo acortarlo? Y cada vez es más. El tiempo es a las 16:24 como máximo lo reinicié a las 18:05.

@XaresJ has probado la respuesta?

@PeterHaddad Sí, probé tu respuesta y funcionó. ¡Gracias! lamentablemente no puedo votar tu comentario :/ porque aún no tengo el representante 15.

Cambiar esto:

implementation 'com.firebaseui:firebase-ui-auth:3.2.2'

a esto:

implementation 'com.firebaseui:firebase-ui-auth:3.3.0'

Firebaseui debe ser compatible con la versión de Firebase

Consulte esto:

https://github.com/firebase/FirebaseUI-Android#dependencies